顶牛股票知识网

您好,欢迎访问顶牛股票知识网,我们将竭诚为您服务!

江恩轮中轮指标源码

2021-01-26 22:26分类:江恩轮中轮 阅读:

 

  江恩轮中轮是诸多江恩爱好者喜欢的工具。也是对江恩全部理论的概括和总结,将市场上的短、中和长期循环进行统一的描述,并将市场的价格点位融合到江恩的几何角度中,能很好的帮助投资来分析时间和价位的关系。以下是笔者在网络中找到的指标源码,分享给喜欢江恩轮中轮的朋友!

  INPUT:最近天(30,1,360);当前月:=FRACPART(ROUND(当前日期/100)/100)*100;

  月:=MONTH;日:=DAY;

  N:=if(sysparam(1)=datacount,最近天,datacount-sysparam(1)+1);

  HH:=HHV(HIGH,N);

  LL:=LLV(LOW,N);

  VN:=N;

  IF VN>DATACOUNT THEN

  VN=DATACOUNT+1;

  FOR I=DATACOUNT DOWNTO DATACOUNT-VN+1 DO BEGIN

  HH[I]:=HH[DATACOUNT];

  LL[I]:=LL[DATACOUNT];

  END;

  TMP:=SETLBOUND(hh,DATACOUNT-VN+1);

  TMP:=SETLBOUND(ll,DATACOUNT-VN+1);

  KKH:=BARSLAST(H=HH);

  KKL:=BARSLAST(L=LL);

  N低日:=STRTONUM(NUMTOSTR(REF(DATE,KKL),0));

  N高日:=STRTONUM(NUMTOSTR(REF(DATE,KKH),0));

  多空:=IF(N低日>N高日,2,1),LINETHICK0;

  DATE1:=IF(多空=1,N低日,N高日);

  LLOW:=ref(LOW,BARSLAST(DATE1=DATE));

  H1:=STRTONUM(NUMTOSTR(hh,2));

  L1:=STRTONUM(NUMTOSTR(LLOW,2));

  VERTLINE(DATE=DATE1),COLORFFAAAA,LINETHICK1;

  {DRAWTEXT(DATE=DATE1,SYSPARAM(4)*0.95,'起\n \n\n测\n \n点'),COLORFFFFFF;}

  IF 多空=1 THEN BEGIN

  PARTLINE(DATE>N低日,L1),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.042),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.083),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.125),COLORMAGENTA;

  PARTLINE(DATE>N低日,L1*1.167),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.208),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.25),COLORMAGENTA;

  PARTLINE(DATE>N低日,L1*1.292),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.33),COLORMAGENTA;

  PARTLINE(DATE>N低日,L1*1.375),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.417),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.458),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.5),COLORMAGENTA;

  PARTLINE(DATE>N低日,L1*1.542),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.583),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.625),COLORMAGENTA;

  PARTLINE(DATE>N低日,L1*1.667),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.708),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.75),COLORMAGENTA;

  PARTLINE(DATE>N低日,L1*1.792),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.833),COLORFFFF99,LINEDOT;

  PARTLINE(DATE>N低日,L1*1.875),COLORMAGENTA;

郑重声明:文章来源于网络,仅作为参考,如果网站中图片和文字侵犯了您的版权,请联系我们处理!

上一篇:江恩理论中轮中轮与24节气

下一篇:没有了

相关推荐


推荐阅读

关注我们

    顶牛股票知识网
返回顶部